Version 4.1x

Suite PG2

© Luis Guzmán

 

Index

Starting Loading files

First time you run the program Setting and Folder Form will be pop up. You should define main game folder and some other settings needed and also if you want to load last file opened when starting the program.

By default program start at Browse View and it is switched when you load a file to edit.

There are 7 Main Views:

Browse View   default start view
Campaign View default view for campaign editor
Summary View default view for scenario editor
Units View default view for saved game editor
Map View  
Equipment View default view for e-file editor
Map Editor default view for Map Editor

Views are empty until you load some file (they show labels, but not data). You can select any view using Menu/Views options or pressing its toolbar icon.
If hover mouse you will see tool tips for most options. You have all the time some view selected (its toolbar icon is grayed).

From here you can load a file to edit or just to see it. You will normally do in any of this two ways:

·         Press Menu File and select the choice you want

·         using a Toolbar first 5 icons (the yellow ones) let you browse for a file to load.

Campaigns, scenarios and map files can be loaded also from Browser View by double clicking on a file (.cam .scn or .map files).

When you load a campaign , scenario or saved game, all files needed to show  equipment, countries and icons are loaded also according your settings. If any file is not found you will be prompted to select it, using standard windows browser dialog.

If you load an equipment file only countries and icons are loaded. Map files does not open any other file.

Last file opened is saved as first File Menu item to quickly reload, last four files for each type are saved as recent files for quick re-loading. Note that equipment file is only included on recent file list when you load it explicitly using Menu File or Toolbar

Menus and Toolbar

All main options are included in a menu, but some items are not allowed unless you are on a specific view or until you have loaded a file of certain type.

There are also some very specific options not included on any menu because they are related to some dialogs and have no sense out of them, or because they are more useful as buttons.

Some of the most frequently used options are replicated using toolbar’s icons


 1     2    3    4    5    6    7    8    9   10  11  12  13  14  15  16 17   18  19  20  21  22  23  24

  1. Load Campaign

  2. Load Scenario

  3. Load Saved Game

  4. Load Equipment

  5. Load Map file

  6. Load Countries file (GUI)

  7. Load Icons file (PANZER2)

  8. Save Current active file

  9. Save As Current active file

  10. Setting Files and Folders

  11. Show current Log file

  12. Edit text file

  13. Icons report

  14. Report for active View

  15. Global Changes for active view

  16. Stop sound (notice it is not sound-off, just stop current sound)

  17. Browser View

  18. Campaign View

  19. Summary View

  20. Units View

  21. Map View

  22. Equipment View

  23. Map Editor View

  24. About

GameSets

What is a GameSet?

As you know the game executable file includes inside some code (routines to implement some features), calls to external windows DLL (as directx management) and some data defining things as files to use (EQUIP97, GUI97, MODGEN, ...),  folders to look up files (SCENARIO, .... ) and some other parameters as interface files, base year, .....

Code and external DLL routines can only be changed (I mean without having the sources) by disassembling, understanding and rewriting the binary codes for some of the CPU instructions (ASM pseudo codes) using an hexadecimal editor. This allow changing some of the features making really a new game. That is what 007 did for PGUK102G.exe and 008 has recently made for latest PGUK210.exe  patch.

But those features stored as  data can be modified much more easy, just by replacing some bytes of the executable, once that data address is known. Anyway once changed the executable behavior is somehow different.

We could say that Game set is any executable that can play the game, and let me call Basic Game set  to any of the flies which has different features hacked by changing coded routines (as PGUK102G or PGUK210) and User GameSets to any of them with some further data changed.
 

Why to change the data ?

The main reason to develop the Game set concept and include a user-friendly interface within the Suite, was to allow having different e-file related scenarios & campaigns sharing into a common game folder (so sharing the bigger and more difficult to maintain MAP folder) but without interacting each other, I mean avoiding multiple game installation or moving files when you want to play campaigns for different e-file than you currently have on your main game folder as EQUIP9, which is IMHO the typical solution for handling that.

So the basic and simple reason would be to define different folders & files for each e-file you play often. Instead of moving to a different folder or to make complicated BAT files to rename or move files, you can create and use specific User GameSets to play.
 

How do I use an existing Game set ?

Once created and configured using the Suite, you will find into your main game folder another executable tweaked to use your settings. To play simply select the Game set executable instead of your standard. Basic Game set.
 

How do I create or edit a Game set ?

Use Menu Tools / Game Set Editor. If you want to create a new one, select your PGUK210.exe basic game set, and change folders and files at your taste. You can create new files and folders or pick existing ones. Be sure all fields are shown a OK before saving.

You can also configure a different base year.
If you press Interface files button, you could also select the interface files to use with that executable. For example adding more than 1 shp file for flags, you could configure a different game set for each flag set.

If you have started from a basic game set you should Save As a different name. When replacing an existing game set a backup copy is made automatic.

You can also save your settings as a SET text file (notice it is not an executable and so playable file). This SET file can be retrieved into another executable by importing it. This is intended to preserve our settings if a new patch were released or to make different game set with very few differences.


On Settings Files and Folders window you can configure which game set you want to use, and then Suite will read files and folders as you defined, searching and storing your files accordingly.

Settings

All settings are saved on windows registry and used from there. You can save also as an INI file to retrieve later, as a way for having as many configurations as you want, but Suite uses those settings you have when you press OK button on Settings and Folders dialog. Loading an INI file only replaces data into that dialog.

Registry entry key is showed so you can edit or delete entries using REGEDIT.EXE

(it is a standard windows program you can locate on C:\WINDOWS folder)

There is an internal editor to edit or create text files, but it has no printer options, so an external editor is launched for reports. You can define which one you want to use and if you prefer always to use that external one.

You can define also an alternative folder to place all .MAP files (from here AllMaps Folder) as there is an option to update all .MAP files needed into your SCENARIO folder according the campaigns you have. Be aware that Suite searches for MAP file both on SCENARIO folder and if not found on that All maps folder

Here you should also define where you have placed some other auxiliary text files like icon descriptive text file (panzer2.txt) and sounds descriptive text file (PG2_SFX.txt). You can use the Suite without those files but they worth to use.

If you use French or German releases you can configure default suffix for text files, but be aware that last patch 2.0x only works with English one (.txt files)

By default standard folders are used, but you can use the new GameSet feature to share many e-files on the same game folder (read on changes summary about this new feature); in this cases here is the place you should define which Game Set you want to use. There is also a button to launch Create/Edit GameSets dialog.

How to search for files can be configured also here and scroll speed for Map View.

Browser

The main purpose of this view is to check the files needed to play your campaigns. By default Game Set scenario folder is used to list all the campaigns and their scenarios and AllMaps Folder setting is used to check your MAP files.

The left hand side list shows all the campaigns found into the folder you set. If any critical file is not found it is marked as <NoP> and if any non critical is missed it is marked as <F> and as you expand campaigns and scenarios you can see the files it defines and if any is missing it will be marked.
As soon as you select a campaign its first scenario is also selected. Each time you select a scenario the map assigned is decoded and shown on the right side (unless you have checked it out).
Double click on any editable file to launch the proper editor.

At the middle of the window is a map list panel including all map files existing on selected folder. If you select (click) on any the map picture (if found) will be decoded and shown. You can sort by map name, map number, or for existing status, clicking on the column header. Here you can also change the map number for the selected map file.

Missing picture files for your campaigns are listed below the picture map and below the list there is a button to visit any of the web sites where you download any missing map.

There are also a button to raise the Reports dialog that allows get different kind of info related. Basically you can create a text file reports with all campaigns in a folder, all files needed for each one and/or missing files. There is also an option to update all MAP files needed for all CAM files from the All Map Files folder to your GameSet Scenario folder. From here you can also get a full report for selected campaign including all prototypes available for each scenario.

Campaign Editor

This view lets you create or edit any campaign and their related text files. All other files as SCN, SMK, MUS can be defined by typing or selected using a windows file browser.

You can add to, or remove from the campaign any scenario, change sequence order  and of course edit any scenario just double clicking on the list.

There are some features to make global changes along all scenarios defined into the campaign:

·         change prestige setting for each scenario

·         change patch 2.0x features on each scenario

·         change units codes used on all scenarios to be e-file playable or converted to another e-file

·         create specific e-file including all equipment needed for all scenarios

There is also a pop up window to show campaign flow – sequence and dates for all campaign - and another tool to review all campaign details.

You can get a report with all data related and all files missing warning specifically if any critical file is missing. This report will include all available prototypes for each scenario, according each scenario settings (no prototypes, different time frame, …)

About prototypes there is also an option to show prototypes available for the selected scenario. It pops up a form including all equipment you could get. You can change the time frame to see the effect, but changes are not updated to the scenario file, so if you like your new time frame settings, edit the scenario file, go to Summary View, be sure you activate prototype time frame feature (using ver 2.0 features button) and then set the new frame as you have tested.

Scenario Editor

Scenario editing is made using 3 views (see below). This views are used also for save games editing, as they are very similar, although some data and options are different depending on the type of file you have loaded.

Although you can create new scenarios without using the game editor, you must to edit and save using the game editor always before using it in the game, as there are some unknown bytes that nobody fully understand yet so game editor is needed to set properly. Skipping this step can run in troubles later.

You cannot create a new saved game in any way.

There are tools to export converted as a People General (SSI) scenario and to reverse sides and to create an EQUIP file with only those codes used in a scenario or saved game. You can export all units in the scenario to a XUD file to later import selectively.

Global changes can be made by selecting specific scopes to limit changes

See Menu/Scenario & Saves to see all options.

 

Summary View

Here it is found all data related to countries, weather, turns, transport available files used as map file, intro text file (which you can edit also) and switches to set type (user/SSI) and visibility (if show up on game scenario list). Scenario main text file is not editable as map and unit names are managed by the Suite, but scenario title is available for editing.

From this view you can set prestige allocation per turn, patch 2.0x special features, music to play, and all data not related with units and map settings.

If a saved game is loaded campaign summary info is also shown and some additional buttons shows up to access specific features as some data is different depending if file loaded is a scenario or a saved game.

Units View

Here it is all units related data. There is a unit list you can filter and sort with different choices and for the selected unit detailed data is shown.

You can select which icon to show (main, transport, appearance,...) and according that selection equipment data is pop up if you double click on any list item. When you switch from this view to Map View, selected units is maintained and if you switch to Equipment View an automatic filter is set to show only same country and class items.

Some data is different again depending on if file is scenario or saved game.

When editing a scenario, you can add, place multiples copies (clone) or delete units; and also add, edit, copy and paste unit's names.

To manage names, you can copy a unit's name and them paste on a different unit, by creating a new name or assigning the id, so sharing the name item.

So it is very easy to make a generic Corp/Division name, and them paste as a new name in all units belonging, and edit each pasted name to add the regimental identifier.

When selecting equipment codes for main, transport or appearance a form is popped up to select, and you can filter to do it easier.

When setting experience you have a button to set experience bar automatically.

If editing a saved game you can configure leaders (name and attributes) and assign any leader to a unit.

You can fix also a little bug that happens sometimes in game when naming units, by releasing the wrong name (set name to equipment).

There is also a global editing feature where you can change data to all units matching some conditions (filters) and you can set random experience between to values you can edit.

When you set an un deployed unit to deployed, you will be changed to map view to set their location.

There is a toggle to see unit’s cost using old formula or Patch 2.0x one.

To see those bytes not fully understood yet, you can turn on a window to see or change for each unit. Each time you change list selection their unknown bytes will be shown on that left window. You can turn it on using  Edit Bytes  button.

Map View

Here you see and change map settings as deploy, supply, owned and victory hexes.

You can edit also terrain type and roads, but you will be warned that you are editing the MAP file so changes will affect all scenarios using that MAP. If you decide to change the MAP file is better if you save changes as a different name.

By default picture map is shown on strategic view but you can toggle to real size picture and even you can maximize the window to use full size screen. Be aware that game uses 640x480 resolution and you surely are using at least 800x600 or better, so you will see the map smaller but sharper than in game. Map is scrolled as in game as soon as you reach an edge. On real size mode you can even see units as they show in game. You can travel the map using mouse scrolling or to be precise you can use keyboard but you have to press Ctrl in addition to any arrow key.

There are many toggles to filter what you see, either for map settings or units, and for terrain types there is a special form to draw icons for specific terrain types to check easily.

On this view you can deploy or un deploy units using the  Deploy  button. Deploying takes care of changing unit appearance if you try to deploy a ground unit on a sea hex. Anyway you can change while the unit is on HQ list for example to change the unit as to be air-embarked before deploying.

There are specific tools to quickly set terrain type or name hexes. Mechanism is simple, press the appropriate  Copy . . button to load into a special buffer the terrain type, road setting or hex name for selected hex, and then paste on any hex by Clicking while holding Control key (from here Ctrl Click). For units you can move using a similar method, first copy a unit using  Copy Unit  button and then Ctrl Click where you want to left. An alternative method is to drag the unit to a new position (move mouse while pressing left mouse button).

There is also an Allow Stack switch, to define if a unit can be placed into an occupied hex (stacking) or no, when moving or pasting. Of course you can always do it manually by setting same coordinates to several units, but to do by moving a unit into an hex already occupied, you need to set the new switch ON 

There are also a collection of buttons to quickly set owner, supply, deploy or victory hexes same as in game editor.

And when editing an scenario there is also a powerful option to copy a unit on windows clipboard (can be copied from Units View, Map View or another Suite instance) and to paste clones on this Map View using  Paste  button or standard Ctrl V hotkey. Is quite suitable to populate defending units as forts, anti-tank or infantry on cities

Right clicking on any unit pops up a form to see its stats. You can also name units from this view (even creating new names if it is a scenario). And if editing a scenario you can also purchase new units.

Map names can be created and edited. So you can easily name all river hexes or sea hexes copying a name and Ctrl Clicking on each hex you want to be named. Names are not duplicated using this method, only a line in the text file will be created when saving, so if you edit that name later all of them will change, no need to re-edit all of them again.

Names for hexes can be saved to a file or loaded from a file quite compatible with Lasse’s map named tool and map names files you can get in the web.

There is also a global changes tool what allows massive changes - even it allows to convert a 4 players scenario into a 2 players one. Here you can even name all hexes for a terrain type (as a lake or river, or an ocean).

And to see those bytes not fully understood yet, you can turn on a window to see or change for each unit. Each time you change hex position their unknown bytes will be shown on that left window. You can turn it on using Edit Bytes button.

Saved game Editor

You can load and edit SAV, CSV and EML files.

Same views than those explained for Scenario Editor are used, but some data and options will be turned on/off according specifics.

By the moment there is no possibility to add unit nor names but you can change most of data. So if you want to recover your better unit as it was before it was killed, you have to buy any other unit before saving and then change all settings (equipment, experience, etc…) within the Suite. You can even recreate how many enemy units that unit had killed and what scenarios it got its bars.

When editing a .CSV file  Dossier  button lets you get a After Action Report with same options as Vladimir’s tool but using patch 2.0x formulas for Cap.

go to Scenario Editor

Equipment Editor

Equipment file is loaded as soon as you edit a campaign, scenario or saved file, although you can create or load any e-file by itself (loading only this one). Any time an e-file is loaded GUI file is loaded also to read county names and other labels as game does.

Two auxiliary text files are provided (Pablo Schegel had this idea and made the files) PG2_SFX.txt with some comments for MEL files and PANZER2.txt with some comments for icons included on panzer2.dat. Both files are editable to let you customize.

When you select a sound (MEL file) you can set the number you want from 1000-1255 , 2000-2255 or 3000-3255, but you can also select from a list with the files you have in the SFX folder, and for each item it will be appended the note you have set for that sound in the PG2_SFX.TXT file. And you can hear the sound just pressing the test buttons. No conversion is needed anymore, thanks to Proggi’s cooperation.

In a similar way when you will change an icon (or just you want to see them), all icons on panzer2.dat are shown and each icon name will be appended with the comment you have for it on PANZER2.TXT file and the number of times that icon is used. In this dialog, there is a filter option to select only some icons matching a criteria you can define to seek into icon name or icon comments.

You can create a text file with any filtered icon list.

Equipment view is very similar to Units View, a list for items is on left side and for selected item, all data is shown. The list can be filtered and sorted in many ways to help on focus what you want to see better.

And you can also turn on unknown bytes window.

You can add items at the end of the file or before the selected one and it can be added as empty or with same data as selected (clone). You can also copy any item (from this view of from other instance as it is stored on windows clipboard) and paste to replace data on selected item – no unit code is changed, only data. But there is a choice to replace (paste) only item’s name.

You can also remove items and Invalidate any to avoid altering items order.

About equipment names a count is shown for all characters to alert if total length exceed 32 Kbytes. You can also set Puma’s style attributes on name, but shorter as ‘@’ symbol is used instead of brackets pair. You can even customize which attributes you want to add. You can remove at any moment, but be aware that bracketed attributes are removed also.

Same as with units, there is a global changes tool to make batch massive changes, although it can be used either to change a few selective items as it has powerful filtering capabilities to select changes.

A new feature lets you replace instances of some icons (names) with a different ones, as defined on a text file to those of us who like to use always same icons for certain units (like me).

There are also options to export and import items to / from another e-file, and even to convert from /to Peoples General (SSI) slightly different format.

When importing you have several choices:

·         Append imported items

·         Replace a range with imported items

·         Update (replace if existing or adding else) imported items.

When exporting, you have the option to keep codes or to reset codes to the new position on file. Although game does not allow, this tool handles equipment's codes independent of the position they have into the file. This is done so, in order to better manage creating, importing and mixing equipment files as you can export filtered equipments to different EQUIP files to later import and mix.

So if you need to mix files you should keep codes when exporting, and if you only want a smaller very dedicated E-File, you can reset codes and so the E-File will be playable. a LOG file is created as an index to reference the initial code and the new position on the exported file. This file can be used later to adjust unit codes.

So you can make a new equipment file using selected codes from many E-Files easily. But to get a playable EQUI97 file you must run the MakeEquipmentPlayable before using it, as this option sets codes same as the order each item has in the file. If you delete any item you should run also this option.

When this option is run, a LOG file is created in order to be able to fix unit's codes in any scenario or even a whole campaign, using the old-new codes pairs.

A new option allows to check how many scenario units are using an e-file item. You can check all scenarios into a campaign or into a folder. There are filters to see how many items are used (and how) and what are not and you can also get a text report. 

 

Map Editor

This view lets you create or edit a map file. Remember a PG2 map is made of a .MAP file holding all definitions, as terrain type and road settings. The picture map is made up to 12 .SHP files encoded into an special format.
This editor loads the .MAP file and using the map number decodes all MAP*.shp files to show the image, then you can modify both the image (pasting external or copied bitmaps) and the terrain & roads settings. When saving you probably need to save the .MAP file and regenerate the MAP*.shp file according the map number you have defined.
In addition map names can be created and edited to be saved into a map names text file.

To edit an existing map file select Load Map File option on Map Editor menu. When loading an existing .MAP file, a map names file it is searched on MAP folder (the one where MAP*.shp files are located) using the map number, and if any is found it is loaded also to make easy review map names also.

To create a new map file select Create New Map File option on Map Editor menu. Of course If you want to import a PG (the former panzer general game) or AG (allied general) map, you should better use Import from PG or Import from AG options instead. This options will import map definitions, map picture and map names if defined on PG/AG

When creating new map files, you can choose to start loading a bitmap file (map size will be same as the bitmap), from another MAPnnn*.shp or with an empty picture map (you must define its size in this choice) to use a tile library to draw the terrain.

There are also options to load a different image picture into your map file (Load Bitmap) as it can be useful to define settings using a simple Encarta type picture.

At any time you can save the .MAP file, Create the MAP*.shp files for your image or save your image as a bitmap file (normally when you are making changes and need keep changes but the picture is not finishes as to create the SHPs).

You can see the map up to 4 different sizes, from a zoomed out view (strategic) to the real size view (not zoomed), and you have switches to draw a grid (clicking on Grid label will cycle to a different grid color) and to draw some markers to highlight hexes with road, hexes with name or hexes with certain terrain types - using  Terrain Filter  button to select terrain types (and for real size if you prefer icons or labels) -.

How to set / change data ?

Changing data is easy and fast: Left mouse is used to select hexes and Right mouse button is used to handle data.
Ctrl and Shift keys can be used to allow additional options and you can also drag to extend your actions (hold a mouse button and move the mouse while keeping that button pressed).

There are 4 basic modes or data tools: Set Terrain, Set  Roads,  Set Names and Set Tiles and at any time only one is active.

As I said before, Right mouse button handles active mode data. This is as simple as Right Clicking on any hex you want to paste active mode data, but you can also make a selection and then Right Click on any hex belonging to that selection and all selected hexes will be set the same. If clicked outside a selection, only that clicked hex will be changed.

Ctrl and Shift keys will change slightly that behavior:

Dragging the mouse will change data as if you were clicking on any hex (so clearing if Shift key is also pressed)


How to select hexes ?

Just by Left Clicking the mouse, from here you can extend your selection by:

Clicking on a not selected hex, will select it, clearing any previous selection. When Tile Mode is active, selections work a little different as explained below.


Set Tile mode features.  Be aware there is no "undo" feature

While on this mode Left Clicking can be slightly different depending on FreeSelection switch.
The active data,  is the tile you see on the 60x50 rectangular area below the  Set Tile  button. To set:

If the file has more than one 60x50 images it will be taken as a tile library and a window will pop up to show the  images available allowing to select one of them. Once loaded, you can change the selected tile by typing a number or using the left-right arrows below the textbox. To choose a different tile file press again Select tile button.

If the file has a single 60x50 image it will show up on the rectangular area and no window will pop up.
Anyway the tile you see is what will be pasted when you Right Clicking the mouse.

Selection and pasting will depend on some of this switches:

back to index

Miscellaneous

Menu/Tools/Icon Report or Toolbar(13) pops up a window showing all icons used. It shows icon for e-file or scenario/saved game depending on the view you are when launching.

Menu/Tools/Show Panzer2 icons pops up a window showing icons inside panzer2.dat, which is the same as explained on equipment view, but it doesn’t allow selecting any icon. All other features are the same.

Menu/Tools/Map Browser and Report lets you browse for map files, showing it picture map; it lets you get a report of all .MAP files sorted by name or number or both. This option is also available from Browser View using a button.

Toolbar(14) launches specific report for the active view. Each editor/view let you get a report. Reports are created as text files and always the external editor is launched so you have the option to send to a printer or to notice where it has been created to later use it.

Toolbar(11) lets review last log file. When loading files data is checked and if any error or warning is detected it is stored into a text log file. This file is shown as soon as loading is finished and you must close it to continue. This option lets you review later that log file to check again for errors.

At any time you can edit any text file using Menu/Tools/Edit Text File or using Toolbar(12)

Toolbar(15) lets you stop current sound. If you are testing any MEL or MUS file this button allows to stop sounding. It does not turn off the speaker, just stop current sound.